diff CMakeLists.txt @ 325:d52a69f9f029

Add Ini, brand new replacement for Parser
author David Demelier <markand@malikania.fr>
date Sat, 28 Feb 2015 18:53:27 +0100
parents ed3cc10761e4
children 0b576ee64d45
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Feb 27 18:15:33 2015 +0100
+++ b/CMakeLists.txt	Sat Feb 28 18:53:27 2015 +0100
@@ -52,10 +52,11 @@
 option(WITH_DYNLIB "Enable DynLib tests" On)
 option(WITH_FLAGS "Enable Flags tests" On)
 option(WITH_HASH "Enable hash functions tests" On)
+option(WITH_INI "Enable .ini parser" On)
 option(WITH_JSON "Enable Jansson wrapper tests" On)
 option(WITH_OPTIONPARSER "Enable option parser tests" On)
 option(WITH_PACK "Enable pack functions" On)
-option(WITH_PARSER "Enable parser tests" On)
+option(WITH_PARSER "Enable parser tests (deprecated)" On)
 option(WITH_SOCKETS "Enable sockets tests" On)
 option(WITH_TREENODE "Enable treenode tests" On)
 option(WITH_UTF8 "Enable Utf8 functions tests" On)
@@ -89,6 +90,10 @@
 	add_subdirectory(C++/Tests/Json)
 endif ()
 
+if (WITH_INI)
+	add_subdirectory(C++/Tests/Ini)
+endif ()
+
 if (WITH_OPTIONPARSER)
 	add_subdirectory(C++/Tests/OptionParser)
 endif ()