diff CMakeLists.txt @ 845:00a4720c4874

doc: rewrite documentation in manual pages, closes #1674 Get rid of markdown documentation and the custom generator tools, instead use raw manual pages.
author David Demelier <markand@malikania.fr>
date Mon, 08 Jul 2019 16:15:57 +0200
parents 2ecff01d4277
children 6af323b76970
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Jul 09 15:04:04 2019 +0200
+++ b/CMakeLists.txt	Mon Jul 08 16:15:57 2019 +0200
@@ -44,6 +44,7 @@
 # libirccd-daemon           - The irccd bot library.
 # irccd                     - The irccd executable.
 # irccdctl                  - The irccdctl utility.
+# man                       - Manual pages.
 # plugins                   - Official irccd plugins.
 # systemd                   - Unit file for systemd.
 # tests                     - The unit tests.
@@ -74,7 +75,6 @@
 	set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_${CFG} ${CMAKE_BINARY_DIR}/bin/${cfg})
 endforeach ()
 
-include(cmake/function/IrccdBuildHtml.cmake)
 include(cmake/function/IrccdDefineExecutable.cmake)
 include(cmake/function/IrccdDefineLibrary.cmake)
 include(cmake/function/IrccdDefineMan.cmake)
@@ -106,6 +106,7 @@
 add_subdirectory(irccd-test)
 add_subdirectory(systemd)
 add_subdirectory(plugins)
+add_subdirectory(man)
 
 if (IRCCD_WITH_TESTS)
 	include(CTest)
@@ -114,18 +115,18 @@
 
 add_subdirectory(cmake/export)
 
-message("Compiling with the following flags:")
+message("Building with the following flags:")
 message("       General flags:  ${CMAKE_CXX_FLAGS}")
 message("       Debug flags:    ${CMAKE_CXX_FLAGS_DEBUG}")
 message("       Release flags:  ${CMAKE_CXX_FLAGS_RELEASE}")
 message("")
 
-message("Compiling irccd with following options:")
+message("Building irccd with following options:")
 message("       Libedit:        ${IRCCD_WITH_LIBEDIT_MSG}")
 message("       OpenSSL:        ${IRCCD_WITH_SSL_MSG}")
 message("       Javascript:     ${IRCCD_WITH_JS_MSG}")
 message("       Tests:          ${IRCCD_WITH_TESTS_MSG}")
-message("       User docs:      ${IRCCD_WITH_HTML_MSG}")
+message("       Man pages:      ${IRCCD_WITH_MAN_MSG}")
 message("       Doxygen:        ${IRCCD_WITH_DOXYGEN_MSG}")
 message("       Package:        ${IRCCD_PACKAGE_MSG}")
 message("       Systemd:        ${IRCCD_WITH_SYSTEMD_MSG}")