diff lib/CMakeLists.txt @ 136:01df93b56dde

Irccd: implement native plugins, #502 - Add brand new DynlibPlugin to load shared libraries as plugins, - Add a template as documentation.
author David Demelier <markand@malikania.fr>
date Wed, 18 May 2016 22:31:24 +0200
parents be4b9ed19a17
children ff26bd33a45d
line wrap: on
line diff
--- a/lib/CMakeLists.txt	Wed May 18 13:24:50 2016 +0200
+++ b/lib/CMakeLists.txt	Wed May 18 22:31:24 2016 +0200
@@ -38,6 +38,8 @@
 	list(APPEND LIBRARIES ws2_32 shlwapi)
 elseif (IRCCD_SYSTEM_MAC)
 	list(APPEND LIBRARIES resolv)
+elseif (IRCCD_SYSTEM_LINUX)
+	list(APPEND LIBRARIES dl)
 endif ()
 
 target_link_libraries(libirccd extern-duktape extern-ircclient extern-jansson cppformat ${LIBRARIES})