diff CMakeLists.txt @ 101:113d909fdfe1

CMake: disallow absolute paths, #389
author David Demelier <markand@malikania.fr>
date Mon, 25 Apr 2016 21:16:47 +0200
parents c67e734c9241
children be4b9ed19a17
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Apr 22 18:50:00 2016 +0200
+++ b/CMakeLists.txt	Mon Apr 25 21:16:47 2016 +0200
@@ -137,23 +137,3 @@
 #
 #	add_dependencies(release package_ifw)
 #endif ()
-
-# Show warnings about non-relocatable irccd.
-if (NOT IRCCD_RELOCATABLE)
-	message("Note: irccd is not relocatable, the following paths are absolute:")
-	message("")
-
-	foreach (path ${IRCCD_ABSOLUTE_PATHS})
-		message("    ${path} is set to ${${path}}")
-	endforeach ()
-
-	message("")
-	message("You can still use irccd, but you won't be able to move the application to a")
-	message("different directory.")
-	message("")
-	message("This may be an issue with some packages manager which allows relocating")
-	message("application in different directories.")
-	message("")
-	message("Set to relative paths if this is a concern.")
-	message("")
-endif ()