diff irccdctl/CMakeLists.txt @ 0:1158cffe5a5e

Initial import
author David Demelier <markand@malikania.fr>
date Mon, 08 Feb 2016 16:43:14 +0100
parents
children 98ac3c79009f
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/irccdctl/CMakeLists.txt	Mon Feb 08 16:43:14 2016 +0100
@@ -0,0 +1,83 @@
+# # CMakeLists.txt -- CMake build system for irccd
+#
+# Copyright (c) 2013-2016 David Demelier <markand@malikania.fr>
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+# Project
+project(irccdctl)
+
+irccd_define_executable(
+	TARGET irccdctl
+	INSTALL
+	SOURCES
+		CMakeLists.txt
+		alias.cpp
+		alias.h
+		command.h
+		command-help.cpp
+		command-help.h
+		command-plugin-info.cpp
+		command-plugin-info.h
+		command-plugin-list.cpp
+		command-plugin-list.h
+		command-plugin-load.cpp
+		command-plugin-load.h
+		command-plugin-reload.cpp
+		command-plugin-reload.h
+		command-plugin-unload.cpp
+		command-plugin-unload.h
+		command-server-cmode.cpp
+		command-server-cmode.h
+		command-server-cnotice.cpp
+		command-server-cnotice.h
+		command-server-connect.cpp
+		command-server-connect.h
+		command-server-disconnect.cpp
+		command-server-disconnect.h
+		command-server-info.cpp
+		command-server-info.h
+		command-server-invite.cpp
+		command-server-invite.h
+		command-server-join.cpp
+		command-server-join.h
+		command-server-kick.cpp
+		command-server-kick.h
+		command-server-list.cpp
+		command-server-list.h
+		command-server-me.cpp
+		command-server-me.h
+		command-server-message.cpp
+		command-server-message.h
+		command-server-mode.cpp
+		command-server-mode.h
+		command-server-nick.cpp
+		command-server-nick.h
+		command-server-notice.cpp
+		command-server-notice.h
+		command-server-part.cpp
+		command-server-part.h
+		command-server-reconnect.cpp
+		command-server-reconnect.h
+		command-server-topic.cpp
+		command-server-topic.h
+		command-watch.cpp
+		command-watch.h
+		connection.cpp
+		connection.h
+		irccdctl.cpp
+		irccdctl.h
+		main.cpp
+	LIBRARIES common
+)
\ No newline at end of file