diff tests/CMakeLists.txt @ 0:1158cffe5a5e

Initial import
author David Demelier <markand@malikania.fr>
date Mon, 08 Feb 2016 16:43:14 +0100
parents
children f113796cfbf9
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/tests/CMakeLists.txt	Mon Feb 08 16:43:14 2016 +0100
@@ -0,0 +1,39 @@
+#
+# CMakeLists.txt -- CMake build system for irccd
+#
+# Copyright (c) 2013-2016 David Demelier <markand@malikania.fr>
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+# Project
+project(tests)
+
+if (WITH_TESTS)
+	# Misc
+	add_subdirectory(elapsedtimer)
+	add_subdirectory(path)
+	add_subdirectory(rules)
+	add_subdirectory(timer)
+	add_subdirectory(util)
+
+	# JS API
+	add_subdirectory(js-elapsedtimer)
+	add_subdirectory(js-file)
+	add_subdirectory(js-irccd)
+	add_subdirectory(js-logger)
+	add_subdirectory(js-system)
+	add_subdirectory(js-timer)
+	add_subdirectory(js-unicode)
+	add_subdirectory(js-util)
+endif ()