diff CMakeLists.txt @ 701:2007a37d7e1a

CMake: prefix options with IRCCD_, #closes 800 @2h
author David Demelier <markand@malikania.fr>
date Wed, 16 May 2018 12:25:51 +0200
parents 808171f7bfa2
children 4b5dba257d81
line wrap: on
line diff
--- a/CMakeLists.txt	Wed May 09 22:34:47 2018 +0200
+++ b/CMakeLists.txt	Wed May 16 12:25:51 2018 +0200
@@ -92,7 +92,7 @@
 add_subdirectory(libirccdctl)
 add_subdirectory(libirccd-test)
 
-if (HAVE_JS)
+if (IRCCD_HAVE_JS)
     add_subdirectory(libirccd-js)
 endif ()
 
@@ -101,7 +101,7 @@
 add_subdirectory(irccd-test)
 add_subdirectory(systemd)
 
-if (HAVE_JS)
+if (IRCCD_HAVE_JS)
     add_subdirectory(plugins)
 endif ()
 
@@ -111,7 +111,7 @@
 endif ()
 
 # Tests.
-if (WITH_TESTS)
+if (IRCCD_WITH_TESTS)
     include(CTest)
     add_subdirectory(tests)
 endif ()
@@ -123,20 +123,20 @@
 message("")
 
 message("Compiling irccd with following options:")
-message("    Libedit:          ${WITH_LIBEDIT_MSG}")
-message("    OpenSSL:          ${WITH_SSL_MSG}")
-message("    JS:               ${WITH_JS_MSG}")
-message("    Tests:            ${WITH_TESTS_MSG}")
-message("    User docs:        ${WITH_HTML_MSG}")
-message("    Doxygen:          ${WITH_DOXYGEN_MSG}")
+message("    Libedit:          ${IRCCD_WITH_LIBEDIT_MSG}")
+message("    OpenSSL:          ${IRCCD_WITH_SSL_MSG}")
+message("    Javascript:       ${IRCCD_WITH_JS_MSG}")
+message("    Tests:            ${IRCCD_WITH_TESTS_MSG}")
+message("    User docs:        ${IRCCD_WITH_HTML_MSG}")
+message("    Doxygen:          ${IRCCD_WITH_DOXYGEN_MSG}")
 message("    Package:          ${IRCCD_PACKAGE_MSG}")
-message("    Vera:             ${WITH_VERA_MSG}")
+message("    Vera:             ${IRCCD_WITH_VERA_MSG}")
 message("")
 
 message("Installing plugins:")
 foreach (plugin ${IRCCD_PLUGINS})
     string(TOUPPER ${plugin} name)
-    irccd_indent_message("    ${plugin}: " "${WITH_PLUGIN_${name}_MSG}" 22)
+    irccd_indent_message("    ${plugin}: " "${IRCCD_WITH_PLUGIN_${name}_MSG}" 22)
 endforeach ()
 message("")