diff extern/libcompat/CMakeLists.txt @ 960:4af3140f234d

misc: various fixes for Alpine Linux
author David Demelier <markand@malikania.fr>
date Mon, 25 Jan 2021 11:11:19 +0100
parents 5e682f1cebcc
children d7501067de95
line wrap: on
line diff
--- a/extern/libcompat/CMakeLists.txt	Sun Jan 24 18:31:50 2021 +0100
+++ b/extern/libcompat/CMakeLists.txt	Mon Jan 25 11:11:19 2021 +0100
@@ -122,6 +122,17 @@
 	endif ()
 endif ()
 
+# Specific BSD sys/queue.h file
+check_include_file(sys/queue.h COMPAT_HAVE_SYS_QUEUE_H)
+
+if (NOT COMPAT_HAVE_SYS_QUEUE_H)
+	target_include_directories(
+		libirccd-compat
+		PUBLIC
+			$<BUILD_INTERFACE:${libirccd-compat_SOURCE_DIR}/extern/queue>
+	)
+endif ()
+
 # Math library
 find_library(COMPAT_HAVE_LIBM m)