diff tests/src/libcommon/stream/CMakeLists.txt @ 780:560b62f6b0a7

Core: rework socket layer, closes #939 @6h Rework the ip_connector and ip_acceptor to be more easy to use. Also, ip_connector will now use a resolver to find appropriate endpoints. Bring back full support for IPv6/IPv4 with all possible combinations. The tls_stream class now owns a shared ssl::context that is copied from the acceptor or the connector. The tls_connector and tls_acceptor wraps basic ones for convenience and simplicity. Irccd and irccdctl now support local SSL sockets.
author David Demelier <markand@malikania.fr>
date Sun, 04 Nov 2018 17:26:05 +0100
parents bfc51f8a00f3
children
line wrap: on
line diff
--- a/tests/src/libcommon/stream/CMakeLists.txt	Thu Nov 01 10:34:21 2018 +0100
+++ b/tests/src/libcommon/stream/CMakeLists.txt	Sun Nov 04 17:26:05 2018 +0100
@@ -17,7 +17,7 @@
 #
 
 irccd_define_test(
-	NAME io
+	NAME stream
 	SOURCES main.cpp
 	LIBRARIES libirccd-core
 )