diff CMakeLists.txt @ 295:6bf457b71e0c

Irccd: add new libirccd-test for unit tests
author David Demelier <markand@malikania.fr>
date Sun, 09 Oct 2016 12:05:11 +0200
parents 7a82aae1ec36
children 04e83ea7147b
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Oct 06 12:36:41 2016 +0200
+++ b/CMakeLists.txt	Sun Oct 09 12:05:11 2016 +0200
@@ -100,8 +100,11 @@
 endif ()
 
 # Tests.
-include(CTest)
-# add_subdirectory(tests)
+if (WITH_TESTS)
+    include(CTest)
+    add_subdirectory(libirccd-test)
+    add_subdirectory(tests)
+endif ()
 
 message("Compiling with the following flags:")
 message("    General flags:    ${CMAKE_CXX_FLAGS}")