diff CMakeLists.txt @ 513:928a40398dec

CMake: split options and conditions, closes #716 As described in the issue, the CMake process force off a cache variable when a condition is not met. If the user installs the requirements and re-run CMake it must also set the variable to on which is inconvenient. The new process is to add a secondary variable and do not touch user defined options.
author David Demelier <markand@malikania.fr>
date Mon, 23 Oct 2017 21:30:17 +0200
parents 6ec510722582
children 68032209609d
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Oct 20 11:43:36 2017 +0200
+++ b/CMakeLists.txt	Mon Oct 23 21:30:17 2017 +0200
@@ -82,7 +82,7 @@
 add_subdirectory(libirccd)
 add_subdirectory(libirccdctl)
 
-if (WITH_JS)
+if (HAVE_JS)
     add_subdirectory(libirccd-js)
 endif ()
 
@@ -90,7 +90,7 @@
 add_subdirectory(irccdctl)
 add_subdirectory(contrib)
 
-if (WITH_JS)
+if (HAVE_JS)
     add_subdirectory(plugins)
 endif ()