diff doc/CMakeLists.txt @ 513:928a40398dec

CMake: split options and conditions, closes #716 As described in the issue, the CMake process force off a cache variable when a condition is not met. If the user installs the requirements and re-run CMake it must also set the variable to on which is inconvenient. The new process is to add a secondary variable and do not touch user defined options.
author David Demelier <markand@malikania.fr>
date Mon, 23 Oct 2017 21:30:17 +0200
parents c6fbb6e0e06d
children bb9771fb5f44
line wrap: on
line diff
--- a/doc/CMakeLists.txt	Fri Oct 20 11:43:36 2017 +0200
+++ b/doc/CMakeLists.txt	Mon Oct 23 21:30:17 2017 +0200
@@ -18,13 +18,13 @@
 
 project(doc)
 
-if (WITH_DOXYGEN)
+if (HAVE_DOXYGEN)
     add_subdirectory(doxygen)
 endif ()
 
 add_subdirectory(examples)
 add_subdirectory(man)
 
-if (WITH_HTML)
+if (HAVE_HTML)
     add_subdirectory(html)
 endif ()