diff tests/src/libcommon/CMakeLists.txt @ 670:95ac3ace1610

Common: introduce new io code To avoid code duplication in accept, connect, reading and writing we add a new set of classes in `io` namespaces located in the following files: - stream.hpp, acceptor.hpp, connector.hpp These classes consist of pure abstract interfaces for I/O. Then we reimplement them in the following files: - socket_stream.hpp, socket_acceptor.hpp, socket_connector.hpp, - tls_stream.hpp, tls_acceptor.hpp, tls_conncetor.hpp (for SSL). This allows future independant connections such as DBus, fifo or any other fancy optional stuff. We also no longer need large class hierarchy such as `connection` for irccdctl controller or transport_server, transport_client classes.
author David Demelier <markand@malikania.fr>
date Tue, 10 Apr 2018 21:20:30 +0200
parents 6eb4caea77a5
children bfc51f8a00f3
line wrap: on
line diff
--- a/tests/src/libcommon/CMakeLists.txt	Fri Apr 06 22:06:07 2018 +0200
+++ b/tests/src/libcommon/CMakeLists.txt	Tue Apr 10 21:20:30 2018 +0200
@@ -17,5 +17,5 @@
 #
 
 add_subdirectory(fs-util)
-add_subdirectory(network-stream)
+add_subdirectory(io)
 add_subdirectory(string-util)