diff CMakeLists.txt @ 72:98ac3c79009f

Irccd: start making a library, #429
author David Demelier <markand@malikania.fr>
date Thu, 24 Mar 2016 14:07:30 +0100
parents f113796cfbf9
children 8ee1178f1219
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Mar 14 11:24:25 2016 +0100
+++ b/CMakeLists.txt	Thu Mar 24 14:07:30 2016 +0100
@@ -34,11 +34,11 @@
 #
 # Build system is then processed in different directories:
 #
-# common			- Static common library between irccd and irccdctl.
 # contrib			- User contributions not maintained by irccd authors.
 # doc				- The documentation process.
 # extern			- External libraries.
-# irccd				- The main irccd executable.
+# lib				- The irccd library
+# irccd				- The irccd executable.
 # irccdctl			- The irccdctl utility.
 # plugins			- Official irccd plugins.
 # tests				- The unit tests.
@@ -67,8 +67,8 @@
 
 add_subdirectory(extern/libircclient)
 add_subdirectory(extern/jansson)
-add_subdirectory(common)
 add_subdirectory(doc)
+add_subdirectory(lib)
 add_subdirectory(irccd)
 add_subdirectory(irccdctl)
 add_subdirectory(contrib)
@@ -122,20 +122,20 @@
 message("")
 
 # CPack (only for package_source, package_ifw is home made).
-include(cmake/IrccdPackage.cmake)
-include(CPack)
+#include(cmake/IrccdPackage.cmake)
+#include(CPack)
 
 # Meta release target.
-if (IRCCD_PACKAGE)
-	add_custom_target(
-		release
-		COMMENT "Releasing irccd ${IRCCD_VERSION}"
-		COMMAND
-			${CMAKE_MAKE_PROGRAM} package_source
-	)
-
-	add_dependencies(release package_ifw)
-endif ()
+#if (IRCCD_PACKAGE)
+#	add_custom_target(
+#		release
+#		COMMENT "Releasing irccd ${IRCCD_VERSION}"
+#		COMMAND
+#			${CMAKE_MAKE_PROGRAM} package_source
+#	)
+#
+#	add_dependencies(release package_ifw)
+#endif ()
 
 # Show warnings about non-relocatable irccd.
 if (NOT IRCCD_RELOCATABLE)