diff CMakeLists.txt @ 710:a17de53db29b

Misc: export libraries Export all libraries with CMake and install headers. While here, build Duktape as object library to avoid exporting it. Don't mix static/dynamic libraries anymore. closes #867 closes #439
author David Demelier <markand@malikania.fr>
date Sat, 07 Jul 2018 14:03:04 +0200
parents 1b04ffb2b35e
children fc66cc9706a7
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Jul 07 10:59:19 2018 +0200
+++ b/CMakeLists.txt	Sat Jul 07 14:03:04 2018 +0200
@@ -49,7 +49,7 @@
 # win32                     - Additional files for Windows platform.
 #
 
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.10)
 project(irccd CXX)
 
 # Helper to set global internal variables.
@@ -115,6 +115,8 @@
     add_subdirectory(tests)
 endif ()
 
+add_subdirectory(cmake/export)
+
 message("Compiling with the following flags:")
 message("    General flags:    ${CMAKE_CXX_FLAGS}")
 message("    Debug flags:      ${CMAKE_CXX_FLAGS_DEBUG}")