diff irccdctl/CMakeLists.txt @ 710:a17de53db29b

Misc: export libraries Export all libraries with CMake and install headers. While here, build Duktape as object library to avoid exporting it. Don't mix static/dynamic libraries anymore. closes #867 closes #439
author David Demelier <markand@malikania.fr>
date Sat, 07 Jul 2018 14:03:04 +0200
parents d30793525261
children fc66cc9706a7
line wrap: on
line diff
--- a/irccdctl/CMakeLists.txt	Sat Jul 07 10:59:19 2018 +0200
+++ b/irccdctl/CMakeLists.txt	Sat Jul 07 14:03:04 2018 +0200
@@ -88,6 +88,7 @@
 
 irccd_define_executable(
     TARGET irccdctl
+    EXPORT
     DESCRIPTION "Irccd controller."
     SOURCES ${SOURCES}
     LIBRARIES libirccdctl