diff tests/plugin-auth/CMakeLists.txt @ 487:beb6c638b841

Tests: create plugin_test fixture, closes #677 Improve plugin tests by using a dedicated fixture which automatically loads the plugin and enable some modules on it.
author David Demelier <markand@malikania.fr>
date Fri, 11 Aug 2017 13:45:42 +0200
parents c6fbb6e0e06d
children
line wrap: on
line diff
--- a/tests/plugin-auth/CMakeLists.txt	Thu Jul 20 15:12:41 2017 +0200
+++ b/tests/plugin-auth/CMakeLists.txt	Fri Aug 11 13:45:42 2017 +0200
@@ -20,5 +20,7 @@
     NAME plugin-auth
     SOURCES main.cpp
     LIBRARIES libirccd
-    FLAGS PLUGINDIR=\"${IRCCD_FAKEROOTDIR}/${WITH_PLUGINDIR}\"
+    FLAGS
+        PLUGIN_NAME="auth"
+        PLUGIN_PATH="${CMAKE_SOURCE_DIR}/plugins/auth/auth.js"
 )