diff CMakeLists.txt @ 823:d76699e13156

cmake: use GetPrerequisites, closes #988 @1h
author David Demelier <markand@malikania.fr>
date Fri, 21 Dec 2018 14:32:57 +0100
parents 49fa22f0b4b9
children 06cc2f95f479
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Nov 30 14:06:13 2018 +0100
+++ b/CMakeLists.txt	Fri Dec 21 14:32:57 2018 +0100
@@ -53,6 +53,7 @@
 project(irccd)
 
 include(GNUInstallDirs)
+include(InstallRequiredSystemLibraries)
 
 # Helper to set global internal variables.
 function(setg var value)
@@ -66,7 +67,6 @@
 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${irccd_SOURCE_DIR}/cmake/packages)
 set(CMAKE_POSITION_INDEPENDENT_CODE On)
 set(CMAKE_WINDOWS_EXPORT_ALL_SYMBOLS On)
-
 set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
 
 foreach (cfg ${CMAKE_CONFIGURATION_TYPES})
@@ -114,10 +114,6 @@
 
 add_subdirectory(cmake/export)
 
-if (CMAKE_SYSTEM_NAME MATCHES "Windows")
-	add_subdirectory(cmake/windows)
-endif ()
-
 message("Compiling with the following flags:")
 message("       General flags:  ${CMAKE_CXX_FLAGS}")
 message("       Debug flags:    ${CMAKE_CXX_FLAGS_DEBUG}")
@@ -141,21 +137,5 @@
 endforeach ()
 message("")
 
-if (CMAKE_SYSTEM_NAME MATCHES "Windows")
-	message("Installing these DLLs:")
-	foreach (name ${IRCCD_DLLS})
-		irccd_indent_message("       ${name}: " "${${name}}" 30)
-	endforeach ()
-	message("")
-
-	if (IRCCD_DLLS_NOT_FOUND)
-		message("The following DLLs were not found:")
-		foreach (name ${IRCCD_DLLS_NOT_FOUND})
-			message("       ${name}")
-		endforeach ()
-		message("")
-	endif ()
-endif ()
-
 include(cmake/IrccdPackage.cmake)
 include(CPack)