diff plugins/CMakeLists.txt @ 768:d8bf53170fb6

Plugin links: fix various errors, closes #912 @2h Import uriparser to decode URLs correctly with fragment and query support for a better link decomposition. Improve pre-check message to allow people writing text after the link, e.g: http://example.org <- you should check this Improve relocation. Split code for better style.
author David Demelier <markand@malikania.fr>
date Wed, 24 Oct 2018 21:05:00 +0200
parents 4b5dba257d81
children 8c44bbcbbab9
line wrap: on
line diff
--- a/plugins/CMakeLists.txt	Tue Oct 23 13:18:21 2018 +0200
+++ b/plugins/CMakeLists.txt	Wed Oct 24 21:05:00 2018 +0200
@@ -52,11 +52,4 @@
     )
 endforeach ()
 
-foreach (plugin ${IRCCD_NATIVE_PLUGINS})
-    irccd_define_plugin(
-        NAME ${plugin}
-        TYPE NATIVE
-        SOURCES ${plugins_SOURCE_DIR}/${plugin}/${plugin}.cpp
-        DOCS ${plugins_SOURCE_DIR}/${plugin}/${plugin}.md
-    )
-endforeach ()
+add_subdirectory(links)