diff tests/CMakeLists.txt @ 662:e9153b85b9bd

Tests: test irccdctl (plugin-* commands) #785 While here, fix many commands that were throwing invalid_message because of missing 'command' JSON property.
author David Demelier <markand@malikania.fr>
date Thu, 29 Mar 2018 09:13:51 +0200
parents 27587ff92a64
children 65a54b126c08
line wrap: on
line diff
--- a/tests/CMakeLists.txt	Wed Mar 28 07:59:03 2018 +0200
+++ b/tests/CMakeLists.txt	Thu Mar 29 09:13:51 2018 +0200
@@ -19,9 +19,27 @@
 # Project
 project(tests)
 
+# Configuration files for irccd/irccdctl
+set(
+    CONFIGS
+    irccd-plugins.conf
+    irccdctl.conf
+)
+
+foreach (c ${CONFIGS})
+    configure_file(
+        ${tests_SOURCE_DIR}/data/${c}
+        ${tests_BINARY_DIR}/${c}
+        @ONLY
+    )
+endforeach ()
+
 # libirccd
 add_subdirectory(src/libirccd)
 
+# irccdctl
+add_subdirectory(src/irccdctl)
+
 # Javascript API and plugins.
 if (HAVE_JS)
     add_subdirectory(src/plugins)