diff CMakeLists.txt @ 711:fc66cc9706a7

CMake: export pkg-config files, closes #874 @1h While here rename libcommon to libirccd-core to avoid collision when installed. For consistency, rename libirccdctl to libirccd-ctl.
author David Demelier <markand@malikania.fr>
date Sat, 07 Jul 2018 15:40:46 +0200
parents a17de53db29b
children 6d09b5fc82e8
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Jul 07 14:03:04 2018 +0200
+++ b/CMakeLists.txt	Sat Jul 07 15:40:46 2018 +0200
@@ -28,8 +28,8 @@
 # cmake/IrccdSystem.cmake   - Contains some platforms checks and compile flags.
 # cmake/IrccdVersion.cmake  - Defines the Irccd version and its plugins.
 # cmake/check               - Platform checks in separate files.
+# cmake/export              - CMake and pkg-config exports.
 # cmake/function            - Custom CMake functions.
-# cmake/installer           - Some files for the QtIFW installer.
 # cmake/internal            - Some internal files (e.g. the sysconfig.h)
 # cmake/packages            - Additional find_package modules.
 #
@@ -37,7 +37,8 @@
 #
 # doc                       - The documentation process.
 # extern                    - External libraries.
-# libirccdctl               - The irccdctl library.
+# libirccd-core             - Common code.
+# libirccd-ctl              - The irccdctl library.
 # libirccd-js               - Javascript bindings library.
 # libirccd-test             - Helpers for unit tests.
 # libirccd                  - The irccd library.
@@ -86,9 +87,9 @@
 
 add_subdirectory(extern/json)
 add_subdirectory(doc)
-add_subdirectory(libcommon)
+add_subdirectory(libirccd-core)
 add_subdirectory(libirccd)
-add_subdirectory(libirccdctl)
+add_subdirectory(libirccd-ctl)
 add_subdirectory(libirccd-test)
 
 if (IRCCD_HAVE_JS)