diff CMakeLists.txt @ 801:fe27ed0c1eae

windows: cleanup .dll installation
author David Demelier <markand@malikania.fr>
date Mon, 12 Nov 2018 21:47:00 +0100
parents 8c44bbcbbab9
children 8460b4a34191
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Nov 12 21:12:00 2018 +0100
+++ b/CMakeLists.txt	Mon Nov 12 21:47:00 2018 +0100
@@ -47,7 +47,6 @@
 # plugins                   - Official irccd plugins.
 # systemd                   - Unit file for systemd.
 # tests                     - The unit tests.
-# win32                     - Additional files for Windows platform.
 #
 
 cmake_minimum_required(VERSION 3.10)
@@ -105,11 +104,6 @@
 	add_subdirectory(plugins)
 endif ()
 
-# Platform specific.
-if (WIN32)
-	add_subdirectory(win32)
-endif ()
-
 # Tests.
 if (IRCCD_WITH_TESTS)
 	include(CTest)
@@ -118,6 +112,10 @@
 
 add_subdirectory(cmake/export)
 
+if (CMAKE_SYSTEM_NAME MATCHES "Windows")
+	add_subdirectory(cmake/windows)
+endif ()
+
 message("Compiling with the following flags:")
 message("       General flags:  ${CMAKE_CXX_FLAGS}")
 message("       Debug flags:    ${CMAKE_CXX_FLAGS_DEBUG}")
@@ -132,7 +130,6 @@
 message("       User docs:      ${IRCCD_WITH_HTML_MSG}")
 message("       Doxygen:        ${IRCCD_WITH_DOXYGEN_MSG}")
 message("       Package:        ${IRCCD_PACKAGE_MSG}")
-message("       Vera:           ${IRCCD_WITH_VERA_MSG}")
 message("")
 
 message("Installing plugins:")
@@ -142,7 +139,7 @@
 endforeach ()
 message("")
 
-if (WIN32)
+if (CMAKE_SYSTEM_NAME MATCHES "Windows")
 	message("Installing these DLLs:")
 	foreach (name ${IRCCD_DLLS})
 		irccd_indent_message("       ${name}: " "${${name}}" 30)