diff doc/CMakeLists.txt @ 138:ff26bd33a45d

CMake: improve VS2015 support, #425
author David Demelier <markand@malikania.fr>
date Thu, 19 May 2016 13:00:00 +0200
parents 113d909fdfe1
children 0ff84eeea2b0
line wrap: on
line diff
--- a/doc/CMakeLists.txt	Thu May 19 12:52:00 2016 +0200
+++ b/doc/CMakeLists.txt	Thu May 19 13:00:00 2016 +0200
@@ -20,7 +20,7 @@
 
 # Meta targets `docs`
 add_custom_target(
-	docs ALL
+	all-docs ALL
 	COMMENT "Building irccd documentation"
 	SOURCES
 		${doc_SOURCE_DIR}/procs/README.md
@@ -31,7 +31,12 @@
 		${doc_SOURCE_DIR}/procs/60.new-command.md
 )
 
-# Needed for fakeroot
+set_target_properties(
+	all-docs
+	PROPERTIES
+		FOLDER meta
+)
+
 if (WITH_DOXYGEN)
 	add_subdirectory(doxygen)
 endif ()