diff plugins/CMakeLists.txt @ 138:ff26bd33a45d

CMake: improve VS2015 support, #425
author David Demelier <markand@malikania.fr>
date Thu, 19 May 2016 13:00:00 +0200
parents 113d909fdfe1
children 6635b9187d71
line wrap: on
line diff
--- a/plugins/CMakeLists.txt	Thu May 19 12:52:00 2016 +0200
+++ b/plugins/CMakeLists.txt	Thu May 19 13:00:00 2016 +0200
@@ -19,10 +19,16 @@
 project(plugins)
 
 add_custom_target(
-	plugins ALL
+	all-plugins ALL
 	COMMENT "Irccd plugins"
 )
 
+set_target_properties(
+	all-plugins
+	PROPERTIES
+		FOLDER meta
+)
+
 foreach (plugin ${IRCCD_PLUGINS})
 	string(TOUPPER ${plugin} optname)
 
@@ -61,6 +67,13 @@
 				${plugin}/${plugin}.md
 		)
 
-		add_dependencies(plugins plugin-${plugin})
+		set_target_properties(
+			plugin-${plugin}
+			PROPERTIES
+				PROJECT_LABEL ${plugin}
+				FOLDER plugins
+		)
+
+		add_dependencies(all-plugins plugin-${plugin})
 	endif ()
 endforeach ()