diff tools/tileset/CMakeLists.txt @ 200:0a285d62ace7

windows: initial VS2017 support While here, do some cleanup in CMake files for a better hierarchy.
author David Demelier <markand@malikania.fr>
date Wed, 28 Nov 2018 22:01:55 +0100
parents 74afc5a41c83
children
line wrap: on
line diff
--- a/tools/tileset/CMakeLists.txt	Tue Oct 30 13:21:55 2018 +0100
+++ b/tools/tileset/CMakeLists.txt	Wed Nov 28 22:01:55 2018 +0100
@@ -18,11 +18,9 @@
 
 project(mlk-tileset)
 
-find_package(Boost REQUIRED QUIET COMPONENTS filesystem system)
-
 malikania_define_executable(
 	TARGET mlk-tileset
-	INCLUDES ${Boost_INCLUDE_DIRS}
-	LIBRARIES ${Boost_LIBRARIES} libmlk
+	FOLDER "tools"
+	LIBRARIES libmlk
 	SOURCES ${mlk-tileset_SOURCE_DIR}/main.cpp
 )