diff client/CMakeLists.txt @ 52:4bc4732fa1dd

Client: add basic button, closes #601
author David Demelier <markand@malikania.fr>
date Thu, 15 Dec 2016 13:46:46 +0100
parents 702e0a2b9e5e
children 9ccc36ba4725
line wrap: on
line diff
--- a/client/CMakeLists.txt	Thu Dec 15 13:43:09 2016 +0100
+++ b/client/CMakeLists.txt	Thu Dec 15 13:46:46 2016 +0100
@@ -16,13 +16,15 @@
 # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
 #
 
-project(client)
+project(mlk-client)
 
 set(
-    FILES
+    SOURCES
     main.cpp
 )
 
-add_executable(mlk-client ${FILES})
-target_include_directories(mlk-client PRIVATE ${client_SOURCE_DIR})
-target_link_libraries(mlk-client libclient-js)
+malikania_define_executable(
+    TARGET mlk-client
+    SOURCES ${SOURCES}
+    LIBRARIES libclient-js
+)