diff examples/sprite/CMakeLists.txt @ 74:78de82cc6bde

Tests: move graphical examples into examples, closes #606
author David Demelier <markand@malikania.fr>
date Thu, 22 Dec 2016 15:17:43 +0100
parents
children a162f380f02e
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/examples/sprite/CMakeLists.txt	Thu Dec 22 15:17:43 2016 +0100
@@ -0,0 +1,36 @@
+#
+# CMakeLists.txt -- CMake build system for malikania
+#
+# Copyright (c) 2013-2016 Malikania Authors
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+malikania_create_test(
+    NAME sprite
+    LIBRARIES libmlk-client
+    SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/main.cpp
+    RESOURCES
+        resources/images/mokodemo.png
+        resources/images/margins.png
+        resources/sprites/no-property-cell.json
+        resources/sprites/no-property-image.json
+        resources/sprites/image-not-found.json
+        resources/sprites/not-object.json
+        resources/sprites/property-image-not-string.json
+        resources/sprites/property-cell-not-array.json
+        resources/sprites/property-cell-not-array2.json
+        resources/sprites/simple.json
+        resources/sprites/margins.json
+)
+