diff libmlk/CMakeLists.txt @ 205:c973501abe36

windows: many fixes for MinGW and VS While here, add more options to malikania_define_library and do not put include directories to assets. Also remove some useless bits.
author David Demelier <markand@malikania.fr>
date Thu, 29 Nov 2018 12:57:30 +0100
parents b1f3f8ec3141
children 10687519f46e
line wrap: on
line diff
--- a/libmlk/CMakeLists.txt	Thu Nov 29 12:41:27 2018 +0100
+++ b/libmlk/CMakeLists.txt	Thu Nov 29 12:57:30 2018 +0100
@@ -45,7 +45,7 @@
 )
 
 if (CMAKE_SYSTEM_NAME MATCHES "Windows")
-	list(APPEND LIBRARIES ws2_32)
+	list(APPEND LIBRARIES ws2_32 mswsock)
 endif ()
 
 malikania_define_library(
@@ -54,7 +54,7 @@
 	SOURCES ${SOURCES}
 	PUBLIC_INCLUDES
 		$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
-	LIBRARIES
+	PUBLIC_LIBRARIES
 		Boost::boost
 		Boost::dynamic_linking
 		Boost::disable_autolinking