diff tests/libclient/js-animation/CMakeLists.txt @ 23:ed63752a8720

Client: add JavaScript bindings for Animation, Animator, #454, #467
author David Demelier <markand@malikania.fr>
date Tue, 05 Apr 2016 21:06:27 +0200
parents
children a1e80d991968
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/tests/libclient/js-animation/CMakeLists.txt	Tue Apr 05 21:06:27 2016 +0200
@@ -0,0 +1,27 @@
+#
+# CMakeLists.txt -- CMake build system for malikania
+#
+# Copyright (c) 2013-2016 Malikania Authors
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+malikania_create_test(
+	NAME js-animation
+	LIBRARIES libclient
+	SOURCES main.cpp
+	RESOURCES
+		resources/animations/margins.json
+		resources/images/margins.png
+		resources/sprites/margins.json
+)