diff libclient/CMakeLists.txt @ 98:f4d23ad4aa27

Common: refactoring class mlk::size 1. Make uniform size representation in JSON format: { "width": 100, "height": 200 } The Javascript API was using this form while an array was used in loaders. 2. Create brand new functions in util::json to parse mlk::size objects, Updated util::json::require_(u)int as well. 3. Add new tests for mlk::size object, 4. Get rid of utilities in loader as they are in util::json instead.
author David Demelier <markand@malikania.fr>
date Tue, 04 Jul 2017 13:23:15 +0200
parents 4031eda60e11
children 119bcc5a727e
line wrap: on
line diff
--- a/libclient/CMakeLists.txt	Fri Jun 16 12:38:04 2017 +0200
+++ b/libclient/CMakeLists.txt	Tue Jul 04 13:23:15 2017 +0200
@@ -37,7 +37,6 @@
     ${libmlk-client_SOURCE_DIR}/malikania/client/mouse.hpp
     ${libmlk-client_SOURCE_DIR}/malikania/client/point.hpp
     ${libmlk-client_SOURCE_DIR}/malikania/client/rectangle.hpp
-    ${libmlk-client_SOURCE_DIR}/malikania/client/size.hpp
     ${libmlk-client_SOURCE_DIR}/malikania/client/sprite.hpp
     ${libmlk-client_SOURCE_DIR}/malikania/client/theme.hpp
     ${libmlk-client_SOURCE_DIR}/malikania/client/unique_layout.hpp