diff libcommon/CMakeLists.txt @ 98:f4d23ad4aa27

Common: refactoring class mlk::size 1. Make uniform size representation in JSON format: { "width": 100, "height": 200 } The Javascript API was using this form while an array was used in loaders. 2. Create brand new functions in util::json to parse mlk::size objects, Updated util::json::require_(u)int as well. 3. Add new tests for mlk::size object, 4. Get rid of utilities in loader as they are in util::json instead.
author David Demelier <markand@malikania.fr>
date Tue, 04 Jul 2017 13:23:15 +0200
parents 301599387b40
children 0addfab87b17
line wrap: on
line diff
--- a/libcommon/CMakeLists.txt	Fri Jun 16 12:38:04 2017 +0200
+++ b/libcommon/CMakeLists.txt	Tue Jul 04 13:23:15 2017 +0200
@@ -24,6 +24,7 @@
     ${libmlk-common_SOURCE_DIR}/malikania/id.hpp
     ${libmlk-common_SOURCE_DIR}/malikania/loader.hpp
     ${libmlk-common_SOURCE_DIR}/malikania/locator.hpp
+    ${libmlk-common_SOURCE_DIR}/malikania/size.hpp
     ${libmlk-common_SOURCE_DIR}/malikania/util.hpp
 )