diff tests/libcommon/CMakeLists.txt @ 98:f4d23ad4aa27

Common: refactoring class mlk::size 1. Make uniform size representation in JSON format: { "width": 100, "height": 200 } The Javascript API was using this form while an array was used in loaders. 2. Create brand new functions in util::json to parse mlk::size objects, Updated util::json::require_(u)int as well. 3. Add new tests for mlk::size object, 4. Get rid of utilities in loader as they are in util::json instead.
author David Demelier <markand@malikania.fr>
date Tue, 04 Jul 2017 13:23:15 +0200
parents 858621081b95
children 6f4965c26ceb
line wrap: on
line diff
--- a/tests/libcommon/CMakeLists.txt	Fri Jun 16 12:38:04 2017 +0200
+++ b/tests/libcommon/CMakeLists.txt	Tue Jul 04 13:23:15 2017 +0200
@@ -17,4 +17,8 @@
 #
 
 add_subdirectory(util)
+add_subdirectory(size)
+
+# JavaScript bindings
 add_subdirectory(js-elapsed-timer)
+add_subdirectory(js-size)