diff CMakeLists.txt @ 199:9ef01392a7f1

tests: make a database test fixture, closes #939 @4h Start PostgreSQL for each test in a clean directory and initialize a malikaniadb within. Only enable unix domain sockets to avoid collision with a system instance. While here, move out the init script into a dedicated file until we find a good solution for initializing databases and upgrading.
author David Demelier <markand@malikania.fr>
date Tue, 30 Oct 2018 13:21:55 +0100
parents 5b0f7ffab962
children 0a285d62ace7
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Nov 27 21:07:00 2018 +0100
+++ b/CMakeLists.txt	Tue Oct 30 13:21:55 2018 +0100
@@ -59,6 +59,7 @@
 
 if (WITH_TESTS)
 	# Unit test libs.
+	add_subdirectory(libmlk-db-test)
 	add_subdirectory(libmlk-js-test)
 	add_subdirectory(libmlk-client-js-test)