diff CMakeLists.txt @ 195:ae3741be8c38

Tests: don't build test libraries if disabled While here, fix a hardcoded string in add_custom_command
author David Demelier <markand@malikania.fr>
date Mon, 29 Oct 2018 13:25:36 +0100
parents 209bdaa13a49
children 5b0f7ffab962
line wrap: on
line diff
--- a/CMakeLists.txt	Sun Oct 28 10:01:44 2018 +0100
+++ b/CMakeLists.txt	Mon Oct 29 13:25:36 2018 +0100
@@ -57,11 +57,11 @@
 add_subdirectory(mlk-client)
 add_subdirectory(mlk-server)
 
-# Unit test libs.
-add_subdirectory(libmlk-js-test)
-add_subdirectory(libmlk-client-js-test)
+if (WITH_TESTS)
+	# Unit test libs.
+	add_subdirectory(libmlk-js-test)
+	add_subdirectory(libmlk-client-js-test)
 
-if (WITH_TESTS)
 	enable_testing()
 	add_subdirectory(tests)
 endif ()