diff libmlk-adventure/CMakeLists.txt @ 259:16be1ad3ddba

adventure: start working on maps and teleport
author David Demelier <markand@malikania.fr>
date Sun, 06 Dec 2020 11:22:03 +0100
parents 71b3b7036de7
children 60a214ec1ab4
line wrap: on
line diff
--- a/libmlk-adventure/CMakeLists.txt	Sat Dec 05 15:57:02 2020 +0100
+++ b/libmlk-adventure/CMakeLists.txt	Sun Dec 06 11:22:03 2020 +0100
@@ -20,6 +20,8 @@
 
 set(
 	SOURCES
+	${libadventure_SOURCE_DIR}/adventure/actions/teleport.c
+	${libadventure_SOURCE_DIR}/adventure/actions/teleport.h
 	${libadventure_SOURCE_DIR}/adventure/adventure_p.h
 	${libadventure_SOURCE_DIR}/adventure/molko.c
 	${libadventure_SOURCE_DIR}/adventure/molko.h
@@ -27,6 +29,8 @@
 	${libadventure_SOURCE_DIR}/adventure/trace_hud.h
 	${libadventure_SOURCE_DIR}/adventure/state/mainmenu.c
 	${libadventure_SOURCE_DIR}/adventure/state/mainmenu.h
+	${libadventure_SOURCE_DIR}/adventure/state/map.c
+	${libadventure_SOURCE_DIR}/adventure/state/map.h
 	${libadventure_SOURCE_DIR}/adventure/state/panic.c
 	${libadventure_SOURCE_DIR}/adventure/state/panic.h
 	${libadventure_SOURCE_DIR}/adventure/state/splashscreen.c
@@ -43,6 +47,23 @@
 )
 
 set(
+	MAPS
+	${libadventure_SOURCE_DIR}/assets/maps/map-world.json
+)
+
+set(
+	TILESETS
+	${libadventure_SOURCE_DIR}/assets/maps/tileset-world.json
+)
+
+set(
+	DATA
+	${libadventure_SOURCE_DIR}/assets/maps/animation-water.png
+	${libadventure_SOURCE_DIR}/assets/maps/sprite-world.png
+	${libadventure_SOURCE_DIR}/assets/sprites/john.png
+)
+
+set(
 	PO
 	${libadventure_SOURCE_DIR}/nls/fr.po
 )
@@ -50,8 +71,11 @@
 molko_define_library(
 	TARGET libmlk-adventure
 	TRANSLATIONS fr
-	SOURCES ${SOURCES} ${PO} ${ASSETS}
+	SOURCES ${SOURCES} ${PO} ${ASSETS} ${MAPS} ${TILESETS}
+	MAPS ${MAPS}
+	TILESETS ${TILESETS}
 	ASSETS ${ASSETS}
+	DATA ${DATA}
 	LIBRARIES libmlk-core libmlk-ui libmlk-rpg
 	PRIVATE_INCLUDES
 		${libadventure_SOURCE_DIR}/adventure