diff examples/CMakeLists.txt @ 136:30b68089ae70

core: rework actions and a bit of drawables, closes #2492 In the effort of having as less as possible memory allocation in libcore, the usage of actions and drawable no longer copy the original source parameter to let user pass a heap allocated variable or a static storage one. Update predefined drawable and actions to match these new needs.
author David Demelier <markand@malikania.fr>
date Tue, 13 Oct 2020 09:38:44 +0200
parents 9301c7c84471
children 4eeeccf2b732
line wrap: on
line diff
--- a/examples/CMakeLists.txt	Sun Oct 11 15:01:26 2020 +0200
+++ b/examples/CMakeLists.txt	Tue Oct 13 09:38:44 2020 +0200
@@ -19,6 +19,16 @@
 project(examples)
 
 molko_define_executable(
+	TARGET example-action
+	SOURCES example-action.c
+	FOLDER examples
+	ASSETS
+		${examples_SOURCE_DIR}/assets/sprites/chest.png
+		${examples_SOURCE_DIR}/assets/sprites/people.png
+	LIBRARIES libcore
+)
+
+molko_define_executable(
 	TARGET example-inventory
 	SOURCES example-inventory
 	ASSETS