diff src/adventure/CMakeLists.txt @ 118:3411daa26432

cmake: create macros for building assets, continue #2487 @1h
author David Demelier <markand@malikania.fr>
date Sun, 04 Oct 2020 22:00:20 +0200
parents 0a6683615c73
children
line wrap: on
line diff
--- a/src/adventure/CMakeLists.txt	Sat Oct 03 19:03:22 2020 +0200
+++ b/src/adventure/CMakeLists.txt	Sun Oct 04 22:00:20 2020 +0200
@@ -20,18 +20,18 @@
 
 set(
 	SOURCES
-	${libadventure_SOURCE_DIR}/mainmenu_state.c 
-	${libadventure_SOURCE_DIR}/mainmenu_state.h 
-	${libadventure_SOURCE_DIR}/panic_state.c 
-	${libadventure_SOURCE_DIR}/panic_state.h 
-	${libadventure_SOURCE_DIR}/splashscreen_state.c 
-	${libadventure_SOURCE_DIR}/splashscreen_state.h 
+	${libadventure_SOURCE_DIR}/mainmenu_state.c
+	${libadventure_SOURCE_DIR}/mainmenu_state.h
+	${libadventure_SOURCE_DIR}/panic_state.c
+	${libadventure_SOURCE_DIR}/panic_state.h
+	${libadventure_SOURCE_DIR}/splashscreen_state.c
+	${libadventure_SOURCE_DIR}/splashscreen_state.h
 )
 
-add_library(libadventure ${SOURCES})
-target_link_libraries(libadventure libcore)
-target_include_directories(
-	libadventure
-	PUBLIC
+molko_define_library(
+	TARGET libadventure
+	SOURCES ${SOURCES}
+	LIBRARIES libcore
+	PUBLIC_INCLUDES
 		$<BUILD_INTERFACE:${libadventure_SOURCE_DIR}>
 )