diff extern/libgreatest/CMakeLists.txt @ 119:43e04bf2c350

cmake: add tests, continue #2487 @1h
author David Demelier <markand@malikania.fr>
date Mon, 05 Oct 2020 09:17:11 +0200
parents 0a6683615c73
children d51d9c0c2186
line wrap: on
line diff
--- a/extern/libgreatest/CMakeLists.txt	Sun Oct 04 22:00:20 2020 +0200
+++ b/extern/libgreatest/CMakeLists.txt	Mon Oct 05 09:17:11 2020 +0200
@@ -17,11 +17,11 @@
 #
 
 project(libgreatest)
-add_library(libgreatest INTERFACE)
-target_sources(libgreatest INTERFACE greatest.h)
-target_include_directories(
-	libgreatest
-	INTERFACE
+
+molko_define_library(
+	TARGET libgreatest
+	TYPE INTERFACE
+	SOURCES greatest.h
+	PUBLIC_INCLUDES
 		$<BUILD_INTERFACE:${libgreatest_SOURCE_DIR}>
-		$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
 )