diff libcore/CMakeLists.txt @ 172:6250883b81f0

core: improve save module, closes #2507 - Databases can now be opened in read-only or in read-write modes, - Module is fully reentrant, - SQL commands are in separate files, - Improve tests, - API to get/set property is using a dedicated structure.
author David Demelier <markand@malikania.fr>
date Wed, 21 Oct 2020 12:43:25 +0200
parents eb0a7ab71023
children f6497ec74b49
line wrap: on
line diff
--- a/libcore/CMakeLists.txt	Wed Oct 21 11:47:18 2020 +0200
+++ b/libcore/CMakeLists.txt	Wed Oct 21 12:43:25 2020 +0200
@@ -19,6 +19,14 @@
 project(libcore)
 
 set(
+	SQL_ASSETS
+	${libcore_SOURCE_DIR}/core/assets/sql/init.sql
+	${libcore_SOURCE_DIR}/core/assets/sql/property-get.sql
+	${libcore_SOURCE_DIR}/core/assets/sql/property-remove.sql
+	${libcore_SOURCE_DIR}/core/assets/sql/property-set.sql
+)
+
+set(
 	SOURCES
 	${libcore_SOURCE_DIR}/core/action.c
 	${libcore_SOURCE_DIR}/core/action.h
@@ -80,7 +88,8 @@
 
 molko_define_library(
 	TARGET libcore
-	SOURCES ${SOURCES}
+	SOURCES ${SOURCES} ${SQL_ASSETS}
+	ASSETS ${SQL_ASSETS}
 	LIBRARIES
 		libsqlite
 		SDL2::SDL2
@@ -98,3 +107,4 @@
 )
 
 source_group(core FILES ${SOURCES})
+source_group(core/assets/sql FILES ${SQL_ASSETS})