diff CMakeLists.txt @ 191:633a25df450e

molko-js: miscellaneous fixes While here, import sphinx as experimental documentation.
author David Demelier <markand@malikania.fr>
date Sat, 07 Nov 2020 15:40:34 +0100
parents a5436e15898d
children 78774cc2cc6b
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Nov 07 10:16:38 2020 +0100
+++ b/CMakeLists.txt	Sat Nov 07 15:40:34 2020 +0100
@@ -35,6 +35,7 @@
 endif ()
 
 option(MOLKO_WITH_DOXYGEN "Enable Doxygen build" On)
+option(MOLKO_WITH_DOC "Enable documentation (requires sphinx)" On)
 option(MOLKO_WITH_TESTS "Enable unit tests" On)
 option(MOLKO_WITH_EXAMPLES "Enable build of examples" On)
 
@@ -70,6 +71,10 @@
 add_subdirectory(molko)
 add_subdirectory(molko-js)
 
+if (MOLKO_WITH_DOC)
+	add_subdirectory(doc)
+endif ()
+
 if (MOLKO_WITH_EXAMPLES)
 	add_subdirectory(examples)
 endif ()