diff librpg/CMakeLists.txt @ 215:64f24b482722

rpg: implement tilesets separately, closes #2515 @4h While here: - Add CMake macros, - Update maps, - Add more tests.
author David Demelier <markand@malikania.fr>
date Tue, 17 Nov 2020 20:08:42 +0100
parents ddfe0a211169
children 86b71e1f9dd5
line wrap: on
line diff
--- a/librpg/CMakeLists.txt	Mon Nov 16 21:57:23 2020 +0100
+++ b/librpg/CMakeLists.txt	Tue Nov 17 20:08:42 2020 +0100
@@ -63,6 +63,10 @@
 	${librpg_SOURCE_DIR}/rpg/spell.h
 	${librpg_SOURCE_DIR}/rpg/teleport.c
 	${librpg_SOURCE_DIR}/rpg/teleport.h
+	${librpg_SOURCE_DIR}/rpg/tileset.c
+	${librpg_SOURCE_DIR}/rpg/tileset.h
+	${librpg_SOURCE_DIR}/rpg/tileset-file.c
+	${librpg_SOURCE_DIR}/rpg/tileset-file.h
 	${librpg_SOURCE_DIR}/rpg/walksprite.c
 	${librpg_SOURCE_DIR}/rpg/walksprite.h
 )