diff extern/libsqlite/CMakeLists.txt @ 601:78eb9f7a64f0

cmake: pet some warnings on Xcode
author David Demelier <markand@malikania.fr>
date Thu, 10 Aug 2023 21:11:09 +0200
parents 087468cbf7ab
children
line wrap: on
line diff
--- a/extern/libsqlite/CMakeLists.txt	Fri Mar 31 12:35:37 2023 +0200
+++ b/extern/libsqlite/CMakeLists.txt	Thu Aug 10 21:11:09 2023 +0200
@@ -25,7 +25,11 @@
 )
 
 if (CMAKE_C_COMPILER_ID MATCHES "GNU|Clang")
-	list(APPEND OPTIONS -Wno-unused-parameter)
+	list(APPEND OPTIONS -Wno-unused-parameter -Wno-unused-but-set-variable)
+
+	if (CMAKE_C_COMPILER_ID MATCHES "Clang")
+		list(APPEND OPTIONS -Wno-constant-logical-operand)
+	endif ()
 endif ()
 
 mlk_library(