diff tests/CMakeLists.txt @ 124:7b84764741b6

core: allows loading maps from memory, closes #2489
author David Demelier <markand@malikania.fr>
date Mon, 05 Oct 2020 16:24:37 +0200
parents b3429b26d60d
children 30b68089ae70
line wrap: on
line diff
--- a/tests/CMakeLists.txt	Mon Oct 05 20:01:00 2020 +0200
+++ b/tests/CMakeLists.txt	Mon Oct 05 16:24:37 2020 +0200
@@ -21,10 +21,17 @@
 molko_define_test(TARGET color SOURCES test-color.c)
 molko_define_test(TARGET error SOURCES test-error.c)
 molko_define_test(TARGET inventory SOURCES test-inventory.c)
-#
-# Maps will be revamped.
-# molko_define_test(TARGET map SOURCES test-map.c ASSETS ${tests_SOURCE_DIR}/)
-#
+molko_define_test(
+	TARGET map
+	SOURCES test-map.c
+	ASSETS
+		${tests_SOURCE_DIR}/assets/maps/error-height.map
+		${tests_SOURCE_DIR}/assets/maps/error-tileheight.map
+		${tests_SOURCE_DIR}/assets/maps/error-tilewidth.map
+		${tests_SOURCE_DIR}/assets/maps/error-title.map
+		${tests_SOURCE_DIR}/assets/maps/error-width.map
+		${tests_SOURCE_DIR}/assets/maps/sample-map.map
+)
 molko_define_test(TARGET rbuf SOURCES test-rbuf.c)
 molko_define_test(TARGET save SOURCES test-save.c)
 molko_define_test(TARGET script SOURCES test-script.c)