diff libadventure/CMakeLists.txt @ 197:852d0b7817ce

rpg: map, extreme cleanup, closes #2508 @4h
author David Demelier <markand@malikania.fr>
date Mon, 09 Nov 2020 10:37:36 +0100
parents 629f55f3961e
children 4c24604efcab
line wrap: on
line diff
--- a/libadventure/CMakeLists.txt	Mon Nov 09 10:36:39 2020 +0100
+++ b/libadventure/CMakeLists.txt	Mon Nov 09 10:37:36 2020 +0100
@@ -30,6 +30,8 @@
 
 set(
 	SOURCES
+	${libadventure_SOURCE_DIR}/adventure/molko.c
+	${libadventure_SOURCE_DIR}/adventure/molko.h
 	${libadventure_SOURCE_DIR}/adventure/trace_hud.c
 	${libadventure_SOURCE_DIR}/adventure/trace_hud.h
 )
@@ -40,9 +42,7 @@
 	${libadventure_SOURCE_DIR}/adventure/assets/fonts/lato.ttf
 	${libadventure_SOURCE_DIR}/adventure/assets/fonts/teutonic.ttf
 	${libadventure_SOURCE_DIR}/adventure/assets/fonts/pirata-one.ttf
-	${libadventure_SOURCE_DIR}/adventure/assets/maps/overworld.map
 	${libadventure_SOURCE_DIR}/adventure/assets/sprites/john.png
-	${libadventure_SOURCE_DIR}/adventure/assets/tilesets/world.png
 )
 
 molko_define_library(
@@ -52,8 +52,11 @@
 		${SOURCES}
 	ASSETS ${ASSETS}
 	LIBRARIES libcore libui librpg
+	PRIVATE_INCLUDES
+		${libadventure_SOURCE_DIR}/adventure
 	PUBLIC_INCLUDES
 		$<BUILD_INTERFACE:${libadventure_SOURCE_DIR}>
+	PRIVATE_FLAGS DIRECTORY="${libadventure_SOURCE_DIR}/adventure/assets"
 )
 
 source_group(adventure FILES ${SOURCES})