diff CMakeLists.txt @ 351:955e2f45ba8a

cmake: fix math library
author David Demelier <markand@malikania.fr>
date Wed, 20 Oct 2021 16:31:39 +0200
parents 7d7991f97acf
children 39f5d932941a
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Oct 20 14:18:39 2021 +0200
+++ b/CMakeLists.txt	Wed Oct 20 16:31:39 2021 +0200
@@ -55,6 +55,9 @@
 find_package(SDL2 REQUIRED COMPONENTS image mixer ttf)
 find_package(Jansson REQUIRED)
 
+# POSIX math library isn't available everywhere.
+find_library(M_LIBRARY m)
+
 configure_file(
 	${molko_SOURCE_DIR}/src/config.h.in
 	${molko_BINARY_DIR}/src/config.h