diff examples/CMakeLists.txt @ 148:c577c15df07f

misc: split libraries, closes #2496
author David Demelier <markand@malikania.fr>
date Thu, 15 Oct 2020 10:32:18 +0200
parents 7f1af54bb35a
children b19d076856d2
line wrap: on
line diff
--- a/examples/CMakeLists.txt	Thu Oct 15 09:21:04 2020 +0200
+++ b/examples/CMakeLists.txt	Thu Oct 15 10:32:18 2020 +0200
@@ -25,37 +25,37 @@
 	ASSETS
 		${examples_SOURCE_DIR}/assets/sprites/chest.png
 		${examples_SOURCE_DIR}/assets/sprites/people.png
-	LIBRARIES libcore
+	LIBRARIES librpg
 )
 
 molko_define_executable(
 	TARGET example-font
 	SOURCES example-font.c
-	LIBRARIES libcore
+	LIBRARIES libui
 )
 
 molko_define_executable(
 	TARGET example-inventory
-	SOURCES example-inventory
+	SOURCES example-inventory.c
 	ASSETS
 		${examples_SOURCE_DIR}/assets/images/fish.png
 		${examples_SOURCE_DIR}/assets/images/potion.png
 		${examples_SOURCE_DIR}/assets/images/sword.png
 	FOLDER examples
-	LIBRARIES libcore
+	LIBRARIES librpg
 )
 
 molko_define_executable(
 	TARGET example-label
 	SOURCES example-label.c
-	LIBRARIES libcore
+	LIBRARIES libui
 )
 
 molko_define_executable(
 	TARGET example-message
 	SOURCES example-message.c
 	FOLDER examples
-	LIBRARIES libcore
+	LIBRARIES librpg
 )
 
 molko_define_executable(
@@ -63,15 +63,15 @@
 	SOURCES example-sound.c
 	FOLDER examples
 	ASSETS
-		${examples_SOURCE_DIR}/assets/sounds/vabsounds-romance.ogg 
-	LIBRARIES libcore
+		${examples_SOURCE_DIR}/assets/sounds/vabsounds-romance.ogg
+	LIBRARIES libui
 )
 
 molko_define_executable(
 	TARGET example-drawable
 	SOURCES example-drawable.c
 	FOLDER examples
-	LIBRARIES libcore
+	LIBRARIES libui
 	ASSETS
 		${examples_SOURCE_DIR}/assets/sprites/explosion.png
 )
@@ -80,5 +80,5 @@
 	TARGET example-trace
 	SOURCES example-trace.c
 	FOLDER examples
-	LIBRARIES libcore libadventure
+	LIBRARIES libui libadventure
 )