diff CMakeLists.txt @ 325:cd8b87ddd1e7

examples: bring back to live using CMake
author David Demelier <markand@malikania.fr>
date Sat, 02 Oct 2021 17:47:27 +0200
parents 8f9937403749
children 2ac41a176b5d
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Oct 02 08:33:39 2021 +0200
+++ b/CMakeLists.txt	Sat Oct 02 17:47:27 2021 +0200
@@ -38,7 +38,8 @@
 
 option(MLK_WITH_NLS "Enable NLS support" On)
 option(MLK_WITH_ZSTD "Enable zstd compression" On)
-option(MLK_WITH_TESTS "Enable unit tests" On)
+option(MLK_WITH_TESTS "Enable unit tests" Off)
+option(MLK_WITH_EXAMPLES "Enable examples" Off)
 
 include(cmake/MlkBcc.cmake)
 include(cmake/MlkExecutable.cmake)
@@ -86,3 +87,7 @@
 	enable_testing()
 	add_subdirectory(tests)
 endif ()
+
+if (MLK_WITH_EXAMPLES)
+	add_subdirectory(examples)
+endif ()