diff examples/CMakeLists.txt @ 325:cd8b87ddd1e7

examples: bring back to live using CMake
author David Demelier <markand@malikania.fr>
date Sat, 02 Oct 2021 17:47:27 +0200
parents
children 42a6710629f5
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/examples/CMakeLists.txt	Sat Oct 02 17:47:27 2021 +0200
@@ -0,0 +1,41 @@
+#
+# CMakeLists.txt -- CMake build system for Molko's Adventure
+#
+# Copyright (c) 2020-2021 David Demelier <markand@malikania.fr>
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+project(examples)
+
+set(
+	DIRS
+	example-action
+	example-animation
+	example-audio
+#	example-battle
+	example-cursor
+	example-debug
+	example-drawable
+	example-font
+	example-gridmenu
+	example-label
+	example-message
+	example-sprite
+	example-trace
+	example-ui
+)
+
+foreach (d ${DIRS})
+	add_subdirectory(${d})
+endforeach ()