diff examples/CMakeLists.txt @ 125:d59efa737fcc

cmake: add examples and fix
author David Demelier <markand@malikania.fr>
date Tue, 06 Oct 2020 12:43:29 +0200
parents
children 9301c7c84471
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/examples/CMakeLists.txt	Tue Oct 06 12:43:29 2020 +0200
@@ -0,0 +1,46 @@
+#
+# CMakeLists.txt -- CMake build system for molko
+#
+# Copyright (c) 2020 David Demelier <markand@malikania.fr>
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+project(examples)
+
+molko_define_executable(
+	TARGET example-inventory
+	SOURCES example-inventory
+	ASSETS
+		${examples_SOURCE_DIR}/assets/images/fish.png
+		${examples_SOURCE_DIR}/assets/images/potion.png
+		${examples_SOURCE_DIR}/assets/images/sword.png
+	FOLDER examples
+	LIBRARIES libcore
+)
+
+molko_define_executable(
+	TARGET example-message
+	SOURCES example-message.c
+	FOLDER examples
+	LIBRARIES libcore
+)
+
+molko_define_executable(
+	TARGET example-sound
+	SOURCES example-sound.c
+	FOLDER examples
+	ASSETS
+		${examples_SOURCE_DIR}/assets/sounds/vabsounds-romance.ogg 
+	LIBRARIES libcore
+)