diff examples/CMakeLists.txt @ 192:4ad7420ab678

rpg: add minimalist battle system, continue #2477 @60h - Implement battle as states, - Add basic support for spells (no calculation yet), - Add won/lost state, - Add animations and messages, - Add order.
author David Demelier <markand@malikania.fr>
date Sat, 07 Nov 2020 16:00:39 +0100
parents 604fad63bd9c
children d3ef968745f5
line wrap: on
line diff
--- a/examples/CMakeLists.txt	Sat Nov 07 15:40:34 2020 +0100
+++ b/examples/CMakeLists.txt	Sat Nov 07 16:00:39 2020 +0100
@@ -19,6 +19,24 @@
 project(examples)
 
 molko_define_executable(
+	TARGET example-battle
+	SOURCES
+		${examples_SOURCE_DIR}/example-battle.c
+		${examples_SOURCE_DIR}/battle/spell-fire.c
+		${examples_SOURCE_DIR}/battle/spell-fire.h
+		${examples_SOURCE_DIR}/battle/registry.c
+		${examples_SOURCE_DIR}/battle/registry.h
+	FOLDER examples
+	ASSETS
+		${examples_SOURCE_DIR}/assets/images/haunted-wood.png
+		${examples_SOURCE_DIR}/assets/images/black-cat.png
+		${examples_SOURCE_DIR}/assets/sprites/cursor.png
+		${examples_SOURCE_DIR}/assets/sprites/explosion.png
+		${examples_SOURCE_DIR}/assets/sounds/fire.wav
+	LIBRARIES librpg libadventure
+)
+
+molko_define_executable(
 	TARGET example-action
 	SOURCES example-action.c
 	FOLDER examples